[WP] PHP7.1 で弊害の出たWP Plugin


PHPのバージョンを7.1xに上げた際、当Blogで利用しているWordpressプラグインで弊害が出たもの。
基本的に古いプライグインなので、代替品に変更することで対応する。

wp-tegaki

インストールしているとエラーでダッシュボードも見れなくなる。
FTPで該当プラグインフォルダを削除することで対応。

wp-tegaki を使用している記事については、CSSでWEBフォントを使うクラスを作り、Search Regexプラグインで一括置換。

exp:

[tegaki] を <span class="tegaki"> に置換
[/tegaki] を </span>に置換

[ WordPress の記事内容を一括で置換できるプラグイン Search Regex ]


ak-hs

記事表示時にエラーが発生する。
プラグイン自体も長らく更新されていないので、Responsive Lightbox へ変更。

変更に伴う既存記事の変更は特になし。

[ Responsive Lightbox by dFactory — WordPress プラグイン ]


Add Quicktag

設定保存時にエラーが発生。

Version2.5以上で修正されているので、最新版にアップデートすればOK。


wp-serverinfo

エラーではないが、OSやServerのValueの部分にワーニングが出る。

これといった実害がないので放置。



とりあえずこんなところかなー。

コメントを残す

メールアドレスが公開されることはありません。