DB関連

MySQLとかデータベース関連の記事

[WP] WordPress 2.9 release したが。。。

WordPress 2.9
(WordPress | 日本語)

先日新バージョンが出たので早速アップグレードしようと思ったのだが、

**注意**
2.9 から MySQL バージョンのシステム要件が変更され、4.1.2 以上が必要になりました。

この一文が気になったので、アップグレードする前に確認してみた。

MySQL version

微妙にバージョン届いてねぇぇぇえ

よかったぁ・・実際にアップグレードする前で。

でもこのままじゃこれ以降の WordPress は使えなくなるからなぁ。。なんとかしなくちゃ。
レンタルしてる「さくらインターネット」では「MySQL4.0及びMySQL5.1が利用可能です。」とあるけれど、4.0から5.1への乗り換えってできるのかなぁ。
その辺もふまえて確認してみないと。。
(もう一つの XREA で運用してるほうは MySQLのバージョンが 5.1xx だったので大丈夫そうだ)



[ MySQLを4から5へ(さくら+WPの場合) « Waviaei ]
やはりというか、想像していたようにいったん4.0のDBを削除してからじゃないと5.1のDBは作れないようで…上記サイトを参考にして移行を考えよう。
ただ問題はそれらの作業をする時間が無いってこと;;
年明けまでお預けだな。。

[blog] phpmyadminでDBの文字化け対策

XREAで使用しているWordpressのDBをphpMyAdminで見たときにDB内容が文字化けして困ってたのだけれど、対策法があったのでメモ。

WordPressサーバ移転まとめ
(Odysseygate.com)

※phpmyadminのDBが文字化けしているようであれば、phpmyadminをハックすることで対処できます。(ファイルの位置はご自分の環境に合わせて読み替えてください。例はXREAの場合です)/public_html/log/phpmyadmin/librariesにあるdatabase_interface.lib.phpの中に
PMA_DBI_query(‘SET NAMES ‘ . $mysql_charset . ‘;’, $link,
PMA_DBI_QUERY_STORE);
という二行があるので、この二行をコメントアウト(先頭に//を付加)してやればOKです。

オリジナルファイルは勿論バックアップをとってから、さくっと書き換え、さくっと表示で問題解消。
ありがたや。